
TVM 4155 Numerical modelling and hydraulics    10. March 2014

OpenFOAM homework

OpenFOAM is the most popular open-source CFD program in the world today. In this homework 
we will use the program to determine the coefficient of discharge for a broad-crested spillway. 

OpenFOAM is considered to be a difficult program to learn. This is partially due to that it is 
designed to run on Linux, and partly that the grid generation tools are complicated. In the current 
homework, we will use a Windows version of OpenFOAM. Instead of using the OpenFOAM grid 
editor, snappyHexMesh, we will use SSIIM 2. This will make the learning curve less steep, and 
hopefully make it possible to finish the homework in a reasonable time (around 3-10 hours).

The homework is divided into different parts, which should be carried out sequentially.

1. Installation of blueCFD

BlueCFD is an OpenFOAM version for Windows. It can be downloaded from 
http://code.google.com/p/bluecfd-singlecore/. The download can be done by clicking on the left 
side of the page: blueCFD-SingleCore-2.0-1-setup.exe. Download the program and install it. It is 
possible to install newer versions, but there have been some problems with these versions, so it is 
recommended to use version 2.0-1. 

The post-processor in OpenFOAM is called ParaView. This can be downloaded from http://
www.paraview.org. The OpenFOAM window calls ParaView through a file called Para-
Foam.bat. To make ParaView accessible when the file is called, you can add the following line at 
the top of the ParaFoam.bat file: set PATH=%PATH%; c:\Program Files\ParaView 3.4.12\bin



This will only work if you have installed ParaView version 3.4.12 in the directory Program Files. 
If you have installed another version in another directory, you have to modify the line accord-
ingly.

The ParaFoam.bat file is found in the directory 

c:\Program Files\blueCFD-SingleCore-2.0\OpenFOAM-2.0\bin.

2. Running a tutorial

After installation, you have a program blueCFD-SingleCore-2.0 installed on your PC. Click on 
the program, and on the directory OpenFOAM, and choose the option OpenFOAM Users Guide. 
This is a PDF file. You can start with running the Dam Break tutorial, described in Chapter 2.3 in 
the Users Guide. The tutorial is carried out by opening the Command Line with ming-w32 DP, 
which is in the blueCFD-SingleCore-2.0 program. This command prompt is used to start the 
OpenFOAM solvers, grid generators and post-processing programs. 

In the command prompt, use the command cd to go to the directory: OpenFOAM-2.0 -> tutorials 
-> multiphase -> interFoam -> ras. Copy the input files using the command 

xcopy /S damBreak c:\damBreak\. 

Answer D on the question about the directory. After the files are copied, go to the root directory 
with the command cd \. Then start the grid generator by the command 

blockMesh -case damBreak

After the grid is made, initiate the variables with the command

setFields -case damBreak

Then do the computation by writing the command 

interFoam -case damBreak

The program then runs for a while. After it has stopped, view the result by the command 

paraFoam -case damBreak

After the ParaFoam window opens, click on the green button Apply. Then click on the box where 
it says p, and choose alpha1. Then click on the triangular green “play” button at the top of the 
menu. 

The buttons are circled in the figure on the next page, where also the order they should be pushed 
is given with numbers.



3. Making the grid for the spillway

One of the most effective ways of learning new computer programs is to run a tutorial and modify 
it so that it fits the problem we want to solve. We will modify the damBreak tutorial so that it con-
tains the grid of the spillway. The spillway will be made with SSIIM 2. 



First, install SSIIM 2 on your computer. It can be downloaded 
from the web page http://folk.ntnu.no/nilsol/ssiim. Choose the 
latest 32 bits version. Remember to download the DLL files 
and unzip these in the same directory as you used for the exe-
cutable. You may for example use the directory c:\ssiim\. 
Make a control file, and add the following options: 

F 87 0.02                uniform distribution of vertical cells
F 159 0 0 0 1 0 0    2d grid allowed
G 1 100 11 21 1     allocation of arrays

Note that the control file must not have any .txt or other exten-
sion. If the file has a .txt extension, it has to be renamed.

Then start the program. A window comes up. Go to the menu option View -> GridEditor. We 
now make the plan view of the grid, which will be a channel that is 8 meters long and 1 meter 
wide. Click on Blocks -> Add block, and then click on four points in the white area, roughly 
where the four corners of the channel is. In plan view. No accuracy needed here. The points have 
to be given clockwise, otherwise an error message is given. After you see the green outline of the 
channel, choose the menu option Blocks -> Size block. Choose 81 lines in i-direction and 2 in j-
direction. Then move the four corners to their exact points. This is done by first clicking on one 
point and then choosing the menu option Define -> Give coordinates. Give the coordinates (0,0), 
(0,1), (8,1) and (8,0). Then choose the menu option Generate -> boundary. The outline of the 
channel is then given. 

Next, we want to make the geometry of a broad-crested weir (http://folk.ntnu.no/nilsol/cases/
langkronet). First, choose in the menu View -> Legend. This shows the grid line numbering. Then 
choose in the menu Define -> NoMovePoints mode. Click on the grid line intersections for lines 
i=25, i=35, i=45 and i=55. Note that there are two intersection for each i. So you will get 8 blue 
markers on the grid. If you make a mistake, choose the menu option Define -> Delete NoMove-



Point. After this is ok, choose the menu option Define -> SetNoPointMode. This will allow you to 
click on the grid without adding new NoMovePoints. 

Then we will give an elevated level for the crest of the weir. This is done by clicking on the four 
central blue NoMovePoints, and giving a level by the menu option Define -> Give coordinates. 
Choose the z level 0.6 meters. Afterwards, choose the menu option Generate -> Boundary. This 
creates straight lines between the NoMovePoints. Then choose Generate -> 3D grid. Save the 
grid by choosing File -> Write unstruc file. End the program and restart it. Choose the menu 
option File -> Read unstruc file. You can see the grid by choosing View -> ProfileI.

Before making the OpenFOAM files, the discharge in and out have to be defined. This is done by 
View-> DischargeEditor. The grid seen from above emerges. Choose Side Discharge -> Choose 
Group -> 1. Then Side Discharge -> Give values. A dialog box emerges, where the water dis-
charge is specified in m3/s. Give a value of 1.0 for the inflow discharge. Then choose OK. Then 
click with the mouse on the left sides of the channel, at section 1. Once clicked, the lines change 



colour. Then choose Side Discharge -> Choose Group -> 2. Then Side Discharge -> Give values. 
In the dialog box, click on the Inflow button. This specifies an outflow of the geometry. Give a 
value of 1.0 for the discharge. Then choose OK. Then click on the right side of the grid and see 
this section change colour. Then save the unstruc file again and end the program.

4. Making the input files for OpenFOAM.

The general idea now is to make the grid and boundary files for the SSIIM 2 geometry and copy 
these into the directory of the damBreak tutorial. First, edit SSIIM 2’s control file and add the data 
set F 298 0 1.0e20 0.24. Restart SSIIM 2 and read the unstruc file. Note that version 142 or later 
must be used. Then choose on the menu File -> Write OpenFOAM files. This will make the Open-
FOAM grid files and boundary files. Copy the blockMeshDict file from the ssiim directory to the 
directory damBreak\constant\polymesh. Copy the files U, alpha1, k, epsilon, p_rgh and nut to the 
directory damBreak\0. You have to specify the inflow and outflow water velocity in the U file. 
Edit the U file and give an inlet velocity of 0.4 m/s, instead of the default 0.3. Also, you need to 
specify the outlet velocity. This is done by using the continuity equation and the inflow and out-
flow areas given at the top of the file. Divide the inlet area with the outlet1 area. Multiply this 
with 0.4 and give this number as the velocity in the outlet1 boundary field. Use many decimals, 
otherwise the program will give a continuity error. Set the outlet2 velocity to zero. The outlet1 
area is lower than outlet2, so this will prevent high downstream water levels. The last value on the 
F 298 data set in the SSIIM 2 control file is the level between the two outlet areas. 

5. Running OpenFOAM

Open the command prompt from blueCFD-SingleCore-2.0 as for the tutorial, and do the same 
commands for grid generation, running the program and post-processing. Before you do this, you 
need to edit the gravity file called g, to get the gravity to be in the z direction instead of the y 
direction. Use the Wordpad for doing this. The g file is located in the damBreak/constant direc-
tory. Change the vector (0 -9.81 0) to (0 0 -9.81).

If you want to make the program run for a longer time, you have to increase the running time by 
editing the controlDict file in the damBreak/system directory. 

If you encounter the error “pRefCell or pRefValue not found” when running interFoam, then you 
need to add some data to an input file. In the directory damBreak/system, there is a file called 
fvSolution. Open this file in an editor, for example WordPad. In the file, there is a section called 
PIMPLE. In the brackets enclosing this section, add the following two lines:

pRefCell    0
pRefValue  0

Save the file and try running the interFoam again. 

If you get error messages for files that we are not using, for example alpha1.org and nuTilda, then 
delete these files.  



When looking at the results with paraFoam, you may have to rotate the figure with the mouse, or 
use one of the buttons on the menu to see the spillway from the side. Also, you may need to 
rescale the colours. Choose the variable U first and then alpha1. 

6. Determining the coefficient of discharge

OpenFOAM computes the water fraction in each cell, which is given by the parameter alpha1. 
The coefficient of discharge can be computed from the water discharge and the water level behind 
the weir. The water discharge is given as the inflow velocity times the inflow area. The water 
level behind the weir is more problematic to find. Approximate values can be taken from the 
graphics. For more accurate values, it is necessary to find where the line of alpha1 = 0.5 is 
located. This must be interpolated from values in the grid. To facilitate this interpolation, SSIIM 
writes a file called levels, which gives the cell number and its level in all the grid cells. This file 
can be taken into a spreadsheet, together with the alpha1 values at the last time step from Open-
FOAM. The values from the alpha1 file and levels file will correspond. A figure showing the 
alpha1 file in WordPad is given at the end of this document. Viewing the graphics of cell num-
bers in SSIIM simultaneously as the paraFoam graphics, enables a rough choice of cells where 
alpha1 = 0.5 is located. The more accurate value can then be interpolated using the spreadsheet 
with the levels/alpha1 values. ‘

The figure on the next page shows the cell numbers for the grid as given by SSIIM 2.



The coefficient of discharge, C, is computed by using the following formula:

where Q is the discharge, B is the width of the spillway and H is the vertical distance from the top 
of the spillway to the water level behind the spillway.

Q CBH
1.5

=



water fraction in cell 1

water fraction in cell 17



7. Further information

The accuracy of the results may be affected by the number of cells in the grid. It is possible to 
increase this. The maximum cells in the vertical direction is given on the G 1 data set in the con-
trol file of SSIIM 2. It is also possible to investigate other numerical parameters, such as the time 
step, by modifying the OpenFOAM input files. For example the controlDict file. 

The F 87 data set in the control file of SSIIM 2 decides the distribution of the number of vertical 
cells as the depth varies. The low value given makes SSIIM 2 generate a grid with equal amount of 
cells in the vertical direction over the whole channel. The default value of the F 87 data set is 0.7, 
which gives some wedge cells in the grid. To avoid getting problems with the wedge cells in the 
OpenFOAM grid, the F 299 1 data set has to be given in the control file of SSIIM 2.

8. Vertical spillway walls

The F 64 11 option makes the grid follow the ground without any vertical walls. To model flow 
over a vertical plate, the F 64 0 option can be used. The grid will then be orthogonal, seen in a 
longitudinal profile. By giving higher bed levels at two neigbouring cross-sections, a wall will be 
made. 



9. Level of top of the grid

The default level of the top of the grid in SSIIM 2 is 1 meter. This can be changed by giving in at 
least three surface points in the Grid Editor. These points are given by the menu option Define -> 
Set surfacepoint. Clicking with the mouse in the window will define a point. The three first points 
will form a triangle. Make sure the grid is inside the triangle. Then choose Generate -> Surface 
and Generate -> 3D Grid. A new grid is then made with the new top level of the grid.

10. Limitations

SSIIM 2 uses an unstructured grid, where it is possible to have varying number of grid cells in the 
vertical direction, depending on the water depth. This is done by including tetrahedral cells in the 
grid. Unfortunately, the tetrahedral grid cells seem to be problematic when transferring the grid 
from SSIIM 2 to OpenFOAM. At least if there is a 3D geometry, instead of a 2D like in the cur-
rent example. 


